解决“不能确定应用到此机器的组策略安全性设置”

原创 jingccj  2018-08-19 09:16:41  阅读 190 次 评论 0 条

最近服务器重新装了系统,根据阿里云的建议进行加固系统,操作到本地策略的审核策略时出现了如下图片的问题

“不能确定应用到此机器的组策略安全性设置。

在尝试从本地安全策略数据库

(%windir% \security\database\secedit.sdb)中检索这些设

置时返回的错误为: 参数不正确。

所有本地安全性设置都将被显示,但是不会指出一个给定的

安全性设置是否由组策略定义 。

所有由此用户界面改动的本地安全性设置都可能随后被域级

的策略替代。”

TIM截图20180819090233.jpg

阿里云帮助中心也给出了解决方案,

1.切换到命令提示符状态(运行输入cmd回车进入)。 
2.执行“esentutl /k %windir%\Security\Database\Secedit.sdb”和“esentutl /g %windir%\Security\Database\Secedit.sdb”对secedit.sdb进行检查。 
3.手工备份要修复的数据库文件。 
4.执行“esentutl /p %windir%\Security\Database\Secedit.sdb”进行修复,系统会弹出Warning提示框: 
"You should only run Repair on damaged or corrupted databases.Repair will not apply information in the transaction log files to the database,and may cause information to be lost.Do you wish to proceed?" 
单击OK,开始修复。

在执行第二步的时候提示该数据库文件正在使用不能进行访问。重启一下服务器再执行2、3、4就成功了

TIM截图20180819092700.jpg

本文地址:http://www.dnly.net/post/37.html
版权声明:本文为原创文章,版权归 jingccj 所有,欢迎分享本文,转载请保留出处!

发表评论


表情

还没有留言,还不快点抢沙发?